Route Akamai & Network Telkom

mungkin rekan2 disini banyak yang menerapkan Loadbalancing serta pisah IIX internasional (mangle nice.rsc) menggunakan provider yang berbeda misal Speedy untuk browsing dan Wireless ISP untuk game online nya.

Beberapa kali saya melakukan hal tersebut.. terkadang ada situs2 yang tampilannya jadi aneh, seperti yahoomail yang blank, ym susah login, facebook harus refresh dan sebagainya..

Usut punya usut, ternyata beberapa situs2 besar seperti facebook,friendster, yahoo dll menaruh cache server di Akamai suatu penyedia jasa layanan Content Delivery Network berbasis DNS. Server-servernya akamai ini terletak di provider sebagai value added service untuk mempercepat loading content (semacam cache).
Karena akamai merupakan fitur ekslusifnya provider, -katakanlah server akamai yang ditaruh di Telkom- maka terkadang, jika kita mengaksesnya dari IP address provider lain, tidak akan bisa diakses. sama seperti halnya DNS server telkom jika diakses dari network ISP lain tidak akan menjawab query.

Mungkin akan lebih jelas jika melihat diagram berikut :



Akamai bekerja berdasarkan DNS, misal begini.. ketika traffic keluar dari IP WISP dan melakukan query dns ke facebook.com dns akan menjawab dengan IP 69.63.189.26 (Facebook US), nah kemudian suatu saat, request DNS muncul dari IP speedy ke facebook.com. karena content facebook untuk telkom telah di provide oleh akamai maka DNS server telkom akan menjawab query facebook.com tersebut dengan ip 125.160.18.26 (Facebook Akamai, server berada di datacenter telkom). nah ketika transmisi data pada router anda yang diberikan rules Pisah IIX internasional ke ip 125.x.x.x melaui gateway WISP, maka traffic ke server facebook akamai tersebut akan direject. So jadinya tampilan nya ngeblank deh. (lihat garis-garis warna merah)

Nah bagaimana menyiasati nya?
saya terfikir untuk me-list network Telkom (dimana Akamai berada) dengan cara melihat Looking Glass diRouter BGP OpenIXP

langkah pertama saya coba mencari router telkom yang terhubung langsung dengan openixp 




kemudian setelah ditemukan ip nya yaitu 218.100.27.179 saya kemudian bisa mendapatkan list network yang di routekan via gateway tersebut adalah network milik Telkom.

langkah kedua saya melakukan list semua subnetwork di openixp dengan menggunakan script yang adaDISINI

langkah ketiga, saya lakukan grep untuk subnetwork yang memiliki IP gateway 218.100.27.179





nah, dari list table diatas, kita bisa mengambil hanya network prerfix-nya saja dengan menggunakan script curl dan perl-netmask, dan hasilnya untuk subnet Telkom yang terhubung langsung dengan OpenIXP adalah sebagai berikut :
Code:
61.5.0.0/17
61.94.0.0/16
110.136.0.0/14
110.232.82.0/24
113.11.132.0/24
113.11.155.0/24
113.212.114.0/24
113.212.125.0/24
113.212.126.0/23
114.30.80.0/24
114.30.85.0/24
114.30.86.0/24
117.103.173.0/24
117.103.174.0/24
118.96.0.0/15
118.98.0.0/17
119.252.128.0/23
119.252.131.0/24
119.252.133.0/24
119.252.134.0/24
121.100.19.0/24
121.100.26.0/24
121.101.128.0/21
125.160.0.0/13
146.23.253.0/24
146.23.254.0/24
175.45.184.0/21
175.111.88.0/22
175.111.112.0/21
175.184.248.0/24
180.131.146.0/24
180.240.128.0/17
180.241.0.0/16
180.242.0.0/15
180.244.0.0/14
180.248.0.0/14
180.252.0.0/15
180.254.0.0/16
182.255.0.0/22
192.8.8.0/24
202.43.92.0/22
202.46.24.0/21
202.46.80.0/22
202.46.129.0/24
202.51.56.0/22
202.51.60.0/23
202.52.52.0/24
202.52.58.0/23
202.52.137.0/24
202.58.204.0/22
202.70.132.0/23
202.73.224.0/20
202.133.80.0/20
202.134.0.0/16
202.137.225.0/24
202.137.230.0/24
202.146.137.0/24
202.146.143.0/25
203.99.120.0/24
203.114.224.0/23
203.130.192.0/18
203.189.123.0/24
203.190.50.0/24
203.210.83.0/24
203.217.134.0/23
210.57.208.0/20
218.100.27.179/32
222.124.0.0/16
Lalu bagaimana setalah itu? 
langkah ke kempat, agar traffic yang menuju network Telkom tidak keluar melewati IP WISP, kita harus memberikan policy routing di MikroTik 
ketika dst-address nya ke subnet telkom agar lookup via tabel routing speedy (sesuaikan dengan tabel routing yang anda buat)

Code:
/ip route rule 
add action=lookup comment="" disabled=no dst-address=61.5.0.0/17 table=via-speedy
add action=lookup comment="" disabled=no dst-address=61.94.0.0/16 table=via-speedy
add action=lookup comment="" disabled=no dst-address=110.136.0.0/14 table=via-speedy
add action=lookup comment="" disabled=no dst-address=110.232.82.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=113.11.132.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=113.11.155.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=113.212.114.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=113.212.125.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=113.212.126.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=114.30.80.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=114.30.85.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=114.30.86.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=117.103.173.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=117.103.174.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=118.96.0.0/15 table=via-speedy
add action=lookup comment="" disabled=no dst-address=118.98.0.0/17 table=via-speedy
add action=lookup comment="" disabled=no dst-address=119.252.128.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=119.252.131.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=119.252.133.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=119.252.134.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=121.100.19.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=121.100.26.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=121.101.128.0/21 table=via-speedy
add action=lookup comment="" disabled=no dst-address=125.160.0.0/13 table=via-speedy
add action=lookup comment="" disabled=no dst-address=146.23.253.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=146.23.254.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=175.45.184.0/21 table=via-speedy
add action=lookup comment="" disabled=no dst-address=175.111.88.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=175.111.112.0/21 table=via-speedy
add action=lookup comment="" disabled=no dst-address=175.184.248.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.131.146.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.240.128.0/17 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.241.0.0/16 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.242.0.0/15 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.244.0.0/14 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.248.0.0/14 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.252.0.0/15 table=via-speedy
add action=lookup comment="" disabled=no dst-address=180.254.0.0/16 table=via-speedy
add action=lookup comment="" disabled=no dst-address=182.255.0.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=192.8.8.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.43.92.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.46.24.0/21 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.46.80.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.46.129.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.51.56.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.51.60.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.52.52.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.52.58.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.52.137.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.58.204.0/22 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.70.132.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.73.224.0/20 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.133.80.0/20 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.134.0.0/16 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.137.225.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.137.230.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.146.137.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=202.146.143.0/25 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.99.120.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.114.224.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.130.192.0/18 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.189.123.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.190.50.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.210.83.0/24 table=via-speedy
add action=lookup comment="" disabled=no dst-address=203.217.134.0/23 table=via-speedy
add action=lookup comment="" disabled=no dst-address=210.57.208.0/20 table=via-speedy
add action=lookup comment="" disabled=no dst-address=218.100.27.179/32 table=via-speedy
add action=lookup comment="" disabled=no dst-address=222.124.0.0/16 table=via-speedy
atau bisa juga buat subnet2 tersebut di address list dan lakukan mangle prerouting via gateway speedy (terserah preferensi masing2)

last but not least 
sebenernya ada cara mudah untuk mencari subnet akamai di telkom,
kita bisa memanfaatkan website looking glass seperti robtex.com dan melakukan search untuk akamai.telkom.net.id
yang sebenarnya hanya ada dua subnet yaitu
125.160.16.0/24
125.160.18.0/24 

Search Subnet Akamai





Shared Network/Domain






Demikian sharing oprekan saya kali ini


credit : faisal
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description

Video Gallery

  • Linux
    sekedar informasi, sekarang zimbra sudah diakuisisi oleh VMWare. jadi nantinya logo webmail zimbra kita akan ada logo VMware-nya.
  • Foto
    kalo mau buat efek foto kembar yang penting pilih minimal 3 foto (mau lebih juga terserah anda aj..)yang setingan tempat dan letak kameranya
  • Network
    setelah anda membongkar dus, dan menyiapkan koneksi. yang perlu anda lakukan adalah:
  • Serba-Serbi
    16 Cara Mengikat Sepatu Ala Jepang share buat teman2 & cew ato cow yang senang menggunakan sepatu bertali. Selamat mencoba
  • Tips-Trik
    Jika agan pengguna komputer, pasti sudah tidak asing lagi dengan yang namanya mouse. Mouse adalah salah satu pendamping setia dari komputer. Hampir semua jenis mouse memiliki 3 buah tombol. Tombol kiri, tombol kanan dan tombol scroll yang ada di tengah
  • Windows
    Windows 7 merupakan versi yang jauh lebih baik daripada versi terbaru windows, yaitu windows Vista. Dan windows 7 dilengkapi dengan banyak fitur baru.