3 line 3 Fungsi NO LOAD BALANCING

Masing-masing fungsi
Speedy1 = browsing 
Speedy2 = Poker + Game Selain PB
WanXp = PB only

Topologi jaringan

speedy1(2mbps) ---|
+++++++++++++++|
speedy2(3mbps) ---|--Mikrotik ----HUB---Client 80unit
+++++++++++++++|++++|
wanxp (1mbps)----|++++|
++++++++++++++++++++|
++++++++++++Proxy Transparant

Untuk IP Address masing-masing Interfaces
Code:
/ip address print
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         BROADCAST       INTERFACE                                                                                             
 0   192.168.20.11/24   192.168.20.0    192.168.20.255  speedy1                                                                                               
 1   172.20.88.254/16   172.20.0.0      172.20.255.255  lokal                                                                                                 
 2   192.168.2.11/24    192.168.2.0     192.168.2.255   speedy2                                                                                               
 3   192.168.69.70/24   192.168.69.0    192.168.69.255  wanxp                                                                                                 
 4   192.168.4.1/24     192.168.4.0     192.168.4.255   proxy
Untuk Routing yang pengen menggunakan backup gateway silahkan ditambah.
Click here to enlarge

Berikut settingan mangle untuk proxy hit dan pemisah antara speedy1 dan jaringan wan
Code:
/ip firewall mangle
add action=marks-packet chain=postrouting comment="PROXY HIT LUSCA" disabled=no \
    dscp=12 new-packet-mark=proxy-hit passthrough=no
add action=marks-routing chain=prerouting comment="Point Blank WANXP ONLY" \
    disabled=no dst-address-list=PB new-routing-mark=PB-WANXP passthrough=no \
    src-address=172.20.0.0/16
add action=marks-connection chain=forward comment=\
    "Browsing SPEEDY1 ONLY - NO WANXP" disabled=no dst-address-list=!PB \
    new-connection-mark=Browsing passthrough=yes src-address=172.20.0.0/16
add action=marks-connection chain=forward comment=\
    "Browsing SPEEDY1 ONLY - NO SPEEDY2" disabled=no dst-address-list=!game \
    new-connection-mark=Browsing passthrough=yes src-address=172.20.0.0/16
automatic add IP game to address-list
Code:
/ip firewall filter
add action=add-dst-to-address-list address-list=PB address-list-timeout=0s \
    chain=forward comment="AUTOMATIC ADD IP GAME" disabled=no dst-port=\
    40000-40010 protocol=udp
add action=add-dst-to-address-list address-list=PB address-list-timeout=0s \
    chain=forward comment=PB disabled=no dst-port=\
    39100,39110,39220,39190,49100 protocol=tcp
add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
    chain=forward comment="Ayo Dance" disabled=no dst-port=18901-18909 \
    protocol=tcp
add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
    chain=forward comment="AUTOMATIC ADD IP POKER" disabled=no dst-port=9339 \
    protocol=tcp
add action=add-dst-to-address-list address-list=nice address-list-timeout=0s \
    chain=forward comment="" disabled=no dst-port=843 protocol=tcp

dst ..... (sesuaikan dengan game yg ada)
Rule untuk mengarahkan game selain PB ke speedy2
Code:
/ip firewall mangle
add action=marks-connection chain=prerouting comment="Ayo Dance" disabled=no \
    dst-address-list=nice dst-port=18901-18909 new-connection-mark=Game \
    passthrough=yes protocol=tcp
add action=marks-connection chain=prerouting comment=SealOnline disabled=no \
    dst-address-list=nice dst-port=1818 new-connection-mark=Game passthrough=\
    yes protocol=tcp
add action=marks-connection chain=prerouting comment=LineAge2 disabled=no \
    dst-address-list=nice dst-port=7777 new-connection-mark=Game passthrough=\
    yes protocol=tcp
add action=marks-connection chain=prerouting comment=Poker disabled=no \
    dst-address-list=nice dst-port=9339 new-connection-mark=Game passthrough=\
    yes protocol=tcp
add action=marks-connection chain=prerouting comment=Poker disabled=no \
    dst-address-list=nice dst-port=843 new-connection-mark=Game passthrough=\
    yes protocol=tcp

dst ..... (sesuaikan dengan game yg ada)

add action=marks-routing chain=prerouting comment="ROUTING Game selain PB" \
    connection-mark=Game disabled=no in-interface=lokal new-routing-mark=nice \
    passthrough=no src-address=172.20.0.0/16
add action=marks-connection chain=forward comment="Poker dan Game Selain PB" \
    disabled=no dst-address-list=nice new-connection-mark=Poker-OtherGame \
    passthrough=yes src-address=172.20.0.0/16
add action=marks-packet chain=postrouting comment="" connection-mark=\
    Poker-OtherGame disabled=no new-packet-mark=Poker-OtherGame passthrough=no

Nat masing-masing interface + transparant proxy
Code:
/ip firewall nat
add action=masquerade chain=srcnat comment="Masquerade PB-WANXP" disabled=no dst-address-list=PB out-interface=wanxp routing-mark=PB-WANXP src-address=\
    172.20.0.0/16
add action=masquerade chain=srcnat comment="Masquerade Poker-Game - Speedy2" disabled=no out-interface=speedy2 routing-mark=nice src-address=172.20.0.0/16
add action=masquerade chain=srcnat comment="Masquerade Proxy" disabled=no src-address=192.168.4.0/24
add action=masquerade chain=srcnat comment="Masquerade Browsing Speedy1" disabled=no out-interface=speedy1 src-address=172.20.0.0/16
add action=dst-nat chain=dstnat comment="TRANSPARENT PROXY HIT" disabled=no dst-port=80,8080,81 protocol=tcp routing-mark=!PB-WANXP src-address=!192.168.4.2 \
    to-addresses=192.168.4.2 to-ports=3128

Hasilnya dengan menggunakan torch sebagai berikut:
Semoga dengan settingan di atas tidak ada jalur yang tersesat

1. Torch ke speedy1 = browsing
Click here to enlarge

2. Torch ke speedy2 = Poker + game selain PB
Click here to enlarge

3. Torch ke WanXP = PB Only
Click here to enlarge

Kalau ada yang salah mohon di koreksi maklum masih newbie..
Untuk BW management mohon di sesuaikan sendiri tergantung kesukaan masing-masing dan di forum ini sudah sangat melimpah tutorialnya.

Semoga bermanfaat dan semoga yg copas lebih teliti Click here to enlarge

Catatan: untuk address list nice adalah address game saja.

Refrensi:

.:.Loadbalance PCC + External Proxy +Automatic by pass Proxy
Warnet+game Online Masuk Sini
http://www.forummikrotik.com/article...game-nice.html
http://www.forummikrotik.com/softwar...proxy-hit.html

Source
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description
  • description

Video Gallery

  • Linux
    sekedar informasi, sekarang zimbra sudah diakuisisi oleh VMWare. jadi nantinya logo webmail zimbra kita akan ada logo VMware-nya.
  • Foto
    kalo mau buat efek foto kembar yang penting pilih minimal 3 foto (mau lebih juga terserah anda aj..)yang setingan tempat dan letak kameranya
  • Network
    setelah anda membongkar dus, dan menyiapkan koneksi. yang perlu anda lakukan adalah:
  • Serba-Serbi
    16 Cara Mengikat Sepatu Ala Jepang share buat teman2 & cew ato cow yang senang menggunakan sepatu bertali. Selamat mencoba
  • Tips-Trik
    Jika agan pengguna komputer, pasti sudah tidak asing lagi dengan yang namanya mouse. Mouse adalah salah satu pendamping setia dari komputer. Hampir semua jenis mouse memiliki 3 buah tombol. Tombol kiri, tombol kanan dan tombol scroll yang ada di tengah
  • Windows
    Windows 7 merupakan versi yang jauh lebih baik daripada versi terbaru windows, yaitu windows Vista. Dan windows 7 dilengkapi dengan banyak fitur baru.